
SUPPLEMENTARY MATERIAL  
1. Preparing 3D model files for printing   
 
1.1) Generate a custom molecular model with UCSF Chimera  
 
The first step in preparing a 3D printable model of a biomolecule is to locate or generate a 3D 
molecular data file. Several online databases host 3D molecular data files along with 
associated metadata. 
  

● PubChem (https://pubchem.ncbi.nlm.nih.gov/): a repository of small molecules, 65 
million of which include calculated 3D structures. 

● Protein Databank (PDB) (http://www.rcsb.org): a repository of more than 100,000 
experimentally derived 3D structures of biomolecules. 

● Protein Model Portal (http://www.proteinmodelportal.org): a database of theoretical 
models of biomolecules, generated with molecular modelling software. 

● Electron Microscopy Databank (EMDB) (https://www.ebi.ac.uk/pdbe/emdb/): hosts 3D 
models of macromolecular assemblies derived from EM density maps. 

1.2) Preparing a 3D printable representation of a biomolecule using Chimera 

Chimera (https://www.cgl.ucsf.edu/chimera/) has a straightforward graphical user interface, 
complemented with a powerful command line. To access the latter, go to Favorites > 
Command Line. It will appear at the bottom of the screen. Below we explain how to prepare 
models for 3D printing using both the available pulldown menus as well as commands (the 
latter shown in text boxes). Use of the command line can save time, but requires the user to 
familiarize him/herself with the code. 

The rotational orientation of the molecule can be adjusted by clicking and dragging the left 
mouse button. After making changes to your molecule, you can save the Chimera session with 
File > Save Session which is essential for back-tracking. Fundamental to all operations that 
customize display is selection, which is done with the options under the select menu. 
Selections can also be made graphically by using ctrl + click or ctrl + drag to select a 
rectangular region. Using ctrl + shift adds to a previous selection. The type of selection can 
be set to append, intersect, replace, or subtract with Select > Selection Mode. Selections can 
be saved by using Select > Name Selection. The saved selection can then be selected again 
with Select > Named Selection [selection name] or with the command sel name, where 
name is the name of your selection. All actions that change how the model is displayed are 
restricted to the atoms in the current selection and are essential to combining multiple 
representation types into a single model. 
  
Name selection 
  
namesel NAME - save a selection called NAME 
sel NAME - re-select the saved selection NAME 
Export scene 

 
 
 
 
 

https://pubchem.ncbi.nlm.nih.gov/
http://www.rcsb.org/pdb/home/home.do
http://www.proteinmodelportal.org/
https://www.ebi.ac.uk/pdbe/emdb/


1.2.1) Generating a 3D printable representation in ‘ribbons’  
 
1.2.1.1) Protein 
Ribbon models display the structure of the protein backbone, distinguishing loops, alpha 
helices, and beta sheet as different conformations of the ribbon. However, ribbon models 
present a challenge to 3D printing. The shape of alpha helices and the often complex geometry 
of the backbone creates a large number of overhangs that must be supported. By generating 
ribbons with physical properties that facilitate printing, these challenges can be overcome. 
  
Begin by using Select > All, then Actions > Atoms/bonds > Hide, and Actions > Surface > 
Hide. This will clear the scene so that no other representation types are displayed. Select the 
portion of the biomolecule that you would like to be a ribbon and use Actions > Ribbons > 
Show. To change the ribbon’s appearance go to Tools > Depiction > Ribbon Style Editor. 
This menu allows several parameters of the ribbon's appearance to be specified (Figure S1). 
The thickness of the ribbon is the most important factor for printing success. Ribbons should 
be made as thick as possible without obscuring the shapes of secondary structures. The ribbon 
style editor can also be used to alter the ribbon cross section. This parameter determines the 
geometry of the ribbon exterior and also of the mesh that is exported from Chimera. The default 
cross section will produce a rounded exterior. Using other cross section types, such as squares 
or octagons, will reduce the number of polygons in the output file, which can be desirable when 
working with large files. 

 
Figure S1. Ribbon style editor. Top: Ribbon style editor menu with suggested parameter, and 
examples of customizable cross section. Bottom: Resulting ribbons from shown parameters. For 
additional information on the Ribbon Style Editor, see: 
https://www.cgl.ucsf.edu/chimera/current/docs/ContributedSoftware/ribbonstyle/ribbonstyle.html.  



1.2.1.2) Nucleic acid 
Nucleic acids can also be represented as ribbons. However, the process of preparing nucleic 
acids is slightly different from that of protein, as nucleic acid is composed of two different 
representations for its backbone and base. The sugar phosphate backbone of nucleic acid is 
displayed as regular ribbons, which are edited in the ribbon style editor. While the nucleobases 
are nucleotide objects which have their own properties. To begin, select nucleic acids and use 
Actions > Ribbons > Show. Then use Actions > Atoms/bonds > Nucleotide Objects > On, 
and Actions > Atoms/bonds > Nucleotide Objects > Settings. Within this menu ensure that 
“show backbone as” is set to ribbon and change “show side (sugar/base)” from “fill/slab” to 
either “ladder” or “atoms and bonds”. When bases are displayed as ladders, the rung radius 
can be altered to improve printability; values of 0.8 or greater work well. 
 

 
Figure S2. Nucleic acids helix rendering editor. 
 
 
1.2.2) Generate a 3D printable ‘surface’ representation of the molecule  

1.2.2.1) Adding hydrogens 
If the depiction of every atom is important for the model of interest, such as when using spheres 
to represent a DNA model, hydrogens can be added using the menu: Tools > Structure 
Editing > AddH. 
  
Adding Hydrogen atoms 
  
addh 

 
The surface representation displays the exterior of a molecule. Surfaces are simple to prepare 
and also straightforward to print. Chimera calculates the surface of a molecule by considering 
that each atom has a radius and then rolling a sphere of arbitrary radius over the model to see 
the depth accessible by the probe. If the probe radius is made small, the result is equivalent to 
the spheres representation - as shown in Figure S1. 
Prior to generating a surface, all other components of the representation should be hidden. To 
do so, select everything and then use Actions > Atoms/bonds > Hide, and Actions > Ribbon 
> Hide. To render the surface representation use Actions > Surface > Show, or go to Presets 



> Interactive 3 (hydrophobicity surface), then Presets > Publication. Both options yield the 
same printed results, as silhouettes and shadows don't alter the information in the 3D model 
file. 
  

Surface generation commands 
  
The Van-der-Waals (VDW) radius must be set first, which determines the distance of the 
generated surface from the underlying atoms. To preserve differences between the radii of 
each element, it is optimal to increase the VDW radius for all atoms by the same amount. 
 
vdwdef - 0.5  decreases the surface distance by 0.5 Å 
  
~ vdwdef -  resets the VDW radius to default 
  
vdwdef + 2.0  increases the surface distance by 2.0 Å 
  
If the model is composed of multiple components, they can be separated into chains using 
the split command. This allows the generation of surfaces for specific components of the 
molecule. 
  
Split - separates each chain into a separate model 
  
split atoms selected - splits the current selection into a separate model 
  
Generate surface of atoms 
  
To generate a surface, use the surf command. Include the model # to generate a surface 
for only that model. The grid argument is required, as it specifies the resolution of the 
exported STL.  A grid value of 0.5 gives a result that is not too large, but can still be scaled 
without showing the individual faces in the print. 
  
surf #0 grid 0.5 

 
Figure S3: Surface renderings. Left: Two surfaces with different resolutions. Right: Two surfaces 
rendered using probe radius of 0.5 and 2.0 angstroms. 
 
 
 
 
 
 



1.2.3) Displaying atoms  
 
1.2.3.1) Stick format  
To highlight specific interactions or structural features, selected atoms in a molecule can be 
displayed. The relevant residues can be selected using selection tools, with the mouse, or in 
the sequence panel under Favorites > Sequence. With the correct atoms selected, use 
Actions > Atoms/bonds > Show, then Actions > Atoms/bonds > Stick to render the atoms 
as sticks. 
  
To change the stick radius, select the entire model or the subset of atoms and open the menu 
Actions > Inspect. In the Inspect menu the radius can be changed. The default radius is 
0.2. Increase to around 0.5 for easier printing depending on the scale of the model. 
  
Changing atom stick radius 
 
setattr m stickScale 2 - increases bond radius for all atoms in the model 

  

Figure S4. Examples of printed results using different stick styles. Thickened sticks print more reliably 
and the final model is stronger. 
 
1.2.3.2) Sphere format 
When using the spheres representation, the size of individual atoms or bonds can be altered. 
To change the radius of a selection of atoms, go to Actions > Inspect. Select Inspect: Atom 
and increase the radius. To change the radius of all atoms of a given type, first select them by 
using Select > Chemistry > Element and choosing the atom type. 
  



 
Changing sphere atom radius 
 
The command vdwdef can be used to change atoms sphere radius by either setting it to a 
new value or increasing/decreasing them. It can be applied to the whole model, to specific 
atom type, or to the current selection sel 
  
vdwdef +0.5 - increases bond radius for all atoms in the model by 0.5Å 
vdwdef -0.5 C - decreases bond radius for all carbon atoms by 0.5 Å 
vdwdef 1.5 O - changes bond radius of all oxygen atoms to 1.5 Å 
vdwdef 1.5 sel - changes bond radius of selected atoms to 1 Å 
~vdwdef - resets VDW radius to default 

 
Figure S5. Chimera atom radius. Arginine molecule rendered with default atomic radius and with all 
radii reduced by 0.5 (Custom 1) and with carbon atoms further reduced by 0.3 and nitrogen atoms by 
0.2 (Custom 2). 
 
 
1.2.4) Displaying hydrogen bonds  
 
The display of hydrogen bonds within a molecule adds important information about secondary 
structure and may potentially increasing the stability of the print. To show hydrogen bonds, use 
Tools > Structure Analysis > Find H bond and hit apply. By default, this will display the 
bonds as wires, which have no volume and cannot be included in an STL file. The wires must 
be displayed as sticks. Use Select > Select All and then Actions > Inspect. Use the Inspect 
menu to inspect pseudobonds and change the bond style to stick. 
  
The default radius is 0.2 but should be increased to approximately 0.4. It is good practice to 
keep the hydrogen bond radius smaller than other chemical bonds so they can be easily 
distinguished. The same results can be achieved using the following commands: 
  
Creating hydrogen bonds 
 
hbond - renders hydrogen bonds for all displayed atoms 
hbond selrestrict any - renders hydrogen bonds for atoms in the current selection 
setattr p drawMode 1 - changes bond style from wire to stick 
setattr g stickScale 2.5 - thickens stick radius 



 
Figure S6. Chimera H-bonds. Steps to produce hydrogen bonds using Chimera. Hydrogen bonds are 
displayed as wires by default (left), and must be converted into sticks (center) and then thickened (right). 
 
1.2.5) Displaying struts 
 
Even with the addition of hydrogen bonds, many ribbon models are still too delicate to be 
printed successfully. Struts are physical connections within the model that do not reflect any 
molecular property but add to the mechanical strength, thus facilitating printing and handling. 
Chimera offers a quick way to automatically add struts to a model with the strut command. 
 
Adding automatic struts 
 
To create blue struts of radius 1.0 Å in the carbon alpha of every 70 residues no further than 
8 Å apart, use the command: 
  
struts @ca length 8 loop 70 color blue rad 1.0 fattenRibbon false 

  
Note: The struts command may contain a bug in the version of Chimera you are using. After 
the command is used, the direction of arrows in beta sheets is reversed. If so, open the ribbon 
style editor for a second time and click “apply” to correct the change. 
  
Struts can be created manually in Chimera with the distance measure tool. The distances 
menu can be opened by going to Tools > Structure Analysis > Distances. From there, a 
distance measure can be created between any two atoms that are selected. To add a distance 
measure strut to the backbone atoms of a protein, the ribbon representation must first be 
turned off, and the atoms displayed and selected. After adding the distance pseudobond, the 
ribbon can be turned on again, and the atoms hidden, resulting in a strut between ribbons. 
Distance measures are a type of pseudobond and can be displayed as sticks and thickened 
with the inspect menu or the command line in the same manner as hydrogen bonds. 
  
Note that in the workflow you must use the ribbon style editor to set ribbon scaling after using 
the struts command due to a bug in the struts command that reverses the direction of 
arrowheads. 
 



Instead of distance, one can also create actual bonds by selecting 2 atoms, and using the 
command bond sel. The bond can be removed by selecting it and going to Actions > Atoms 
> Delete. 

 
Figure S7. Chimera struts using distance tool. Top: Steps to create a distance measure pseudobond 
between two atoms. Bottom: to create a pseudobond between two residues, atoms from the backbone 
must be selected by hiding the ribbon representation of the desired residues, showing the atoms, 
creating the distance measure, and then showing the ribbon again. 

1.2.6) Scaling and thickening for printing 
 
Depending on the nature of your biomolecular representation, scaling of the model from the 
default magnification before printing may be essential to success. Most FFF 3D printers do not 
reliably print features smaller than 0.2 mm, which will occur in unscaled ribbon and stick 
models. Ribbon models generally require at least 200% scaling from the default to increase 
the stability of delicate ribbon structures and overhangs. Complex ribbon models may require 
multiple attempts to print correctly. Surface models can usually be printed as small as 50%; 
100% scaling is more reliable. 
 
2. Processing STL files for printing 
 
2.1) Repair STL files with Autodesk Netfabb  
 
A 3D model file generated is often not continuous, but rather a number of pieces with 
intersecting geometries. For example, a hydrogen bond is a cylinder that overlaps with the 
closed surface of a ribbon. This can cause errors when the file is read by some slicing software, 
as regions where two geometries overlap can be interpreted as the exterior of the model. To 
correct this, utilize cleaning software to obtain a continuous mesh from the separate 
geometries within the file. Autodesk Netfabb is a mesh cleaning tool that will correct a number 
of common mesh errors. A limited version of Netfabb, called Netfabb Basic, is freely available 



(https://www.netfabb.com/products/netfabb-basic). It lacks the mesh merging capability of the 
full version, Netfabb Standard. Autodesk offers free educational licenses for Netfabb Standard 
(www.autodesk.com/education/free-software/netfabb). 

 
 
Figure S8. Repairing meshes for printing. Depiction problem that occurs with the STL model hydrogen 
bonds generated by Chimera before being run through Netfabb, and how it looks after. 
 
 
2.2) Orient models for printing with Autodesk Meshmixer  
 
Autodesk MeshMixer is a freely available tool with several functions for manipulating 3D 
meshes, used here to optimally orient models and minimize overhangs for printing. A correctly 
oriented model will print faster, require less support material, and be less likely to fail. To orient 
your model before printing, open Meshmixer and import your model, then use analysis > 
orientation. Four sliders are presented. The overhang angle determines which orientation of 
a triangle relative to the surface is required for it to be considered an overhang. It is acceptable 
to keep this value at the default of 45 degrees. The other three sliders are the part strength, 
support volume, and support area. Changing these sliders adjusts the priority (or weight) of 
optimizing that component. For example, the default setting with Support Volume at 100, 
Strength at 0 and Support Area at 0, will orient the part so that the total volume of supports is 
minimized. For molecular models it is most useful to minimize the number of overhangs. To do 
this set Support Area to 100, Strength to 0 and Support Volume to 0. Click accept and then 
use File>Export and select STL.  It may be useful for the user to experiment with this feature 
to find optimal settings for their models. 
 
 
3. Slicing and printing 
 
3.1) Selecting a filament material 
 
A wide variety of thermoplastic polymers are available for FFF printers. Select a material based 
on the properties required in the printed object and the capabilities of the available printers. 
The most commonly used filaments are polylactic acid (PLA) and acrylonitrile butadiene 

https://www.netfabb.com/products/netfabb-basic
http://www.autodesk.com/education/free-software/netfabb


styrene (ABS). Additionally, thermoplastic elastomers (TPE) are available and can be used to 
create flexible models.  
 
We find that PLA is the most effective material for printing biomolecular models. With a low 
melting temperature and active cooling, PLA prints small parts and bridges gaps better than 
other filaments. Compared to ABS, it produces fewer and less harmful particulates and is 
therefore more suited for unventilated areas. Due to its low melting temperature PLA can be 
actively cooled during the printing process. The application of airflow to the point of extrusion 
causes the filament to solidify rapidly, preventing it from drooping or changing shape. This 
allows small features, overhangs, and bridges to be fabricated accurately. PLA can adhere to 
a build plate that is at room temperature and coated in kapton tape. However, it is advised to 
use a glass bed heated to ~60°C for best results. One drawback of PLA is that is causes more 
friction than ABS and can occasionally jam in printers that use a bowden tube to connect the 
extruder to the hot end. PLA is also less resistant to high temperatures and more brittle than 
ABS. 
 
TPE has similar material properties to PLA but is more difficult to extrude. The use of flexible 
3D printing filament enables the fabrication of models that can mimic some of the dynamic 
properties of biomolecules. Flexible models can assist in studies of protein folding, protein-
protein binding, and ligand-protein binding. Using flexible filament adds utility to both ribbon 
and surface models. The material properties of flexible filament create some specific printing 
challenges. The softness of the filament makes it more likely to buckle when undergoing 
compression, which occurs between the driving gear and the hot end. For printers that use a 
long tube between the drive and hot end (a bowden tube) the filament can jam in the tube and 
prevent extrusion. Some bowden tube printers can print with flexible filament, but only at very 
slow speeds. The softness of the filament also causes issues with retraction. With other 
materials, the reversal of the drive gear is rapidly translated to the hot end and quickly pulls 
the filament away from the surface of the print. Flexible filament will stretch during retraction, 
causing a time lag between the action of the drive gear and the filament retraction at the hot 
end, thus retraction settings should be changed or eliminated for flexible materials. 
  
  Nozzle 

Temperature 
Bed 
temperature 

Active cooling Fumes Flexibility 

PLA 190- 210 60 Yes Minor Brittle 

ABS 235-245 120 No Hazardous, 
unpleasant 
smell 

Minor 

TPE 190-210 60 Yes Minor Significant 
 
 
3.2) Generate G-code 
Slicing is the process of converting a 3D model file into instructions for a 3D printer to create a 
physical replica of the structure. To do this, a 3D shape is sliced into a stack of horizontal layers 
with sequential printer commands. The slicer software is used to define parameters important 
to the printing process, such as object location and orientation, printing temperature, layer 
height, printing speed, interior fill, and supports. These instructions are often referred to as G-
code and .gcode is a common file type used by many desktop 3D printers. The slicer can 
stream instructions directly to the printer or save a .gcode file onto an SD card. 
  
There are many types of slicing software available, including Cura (open source), Slic3r (open 
source), Craftware (freeware), and Simplify3D (proprietary). The instructions in the protocol 



are for Simplify3D, which has a number of features that greatly assist the printing of 
biomolecular models. Simplify3D is the only slicer that allows customization of supports, which 
can be individually added or removed. This is often necessary when preparing ribbon models. 
Additionally, the software is compatible with virtually every desktop FFF printer and has 
optimized profiles for many of them. Although Simplify3D is the best solution for biomolecular 
models our instructions can be adapted to other slicing software, as many settings are 
equivalent or similar. 

3.2.1) Simplify3D 
Supports are temporary structures included in the G-code to enable printing of overhangs. An 
overhang is a part of a print that is at more than 45° away from vertical or a part where the 
lowest section has nothing underneath it. Because material extruded to form overhangs would 
not have anything to connect to, temporary support structures hold overhangs in place until 
they are connected to the rest of the print. Supports are generated by slicing software as the 
print is being prepared. The placement of supports is an important factor to the success of a 
print. They must be sufficient to hold all overhangs in place and must be easy to remove after 
printing. 
 

 
 
Figure S9. Supports in Simplify3D. Top Left: slicing preview and printed result of a test model with and 
without supports, showing drooping that occurs. Bottom Left: Slicing preview and printed results of 
histone monomer surface prior to support removal. Right: Cross section of the toolpath generated by 
Simplify3D for a sphere, allowing the user to inspect for possible problems. 
 
Simplify3D has very effective support structure generation and editing tools. Support structures 
should first be generated automatically, using an overhang threshold between 45° to 60°, 
depending on the properties of the printer. The resolution of the supports can be defined; finer 
resolution will provide better support, but will be more difficult to remove. 
  
After automatic supports have been generated, the supports should be inspected and edited 
as necessary. The support generator will miss some sharp bottom angles, so extra supports 
should be added to the lowest points of ribbons. Supports should be removed from crevices 
where they could not be removed from the physical model, such as inside binding pockets on 
surface models, and inside alpha helices in ribbons. 

The cross section tool can be used to visualize where supports are being added. It also makes 
it easier to remove supports within crevices when there is no direct line of sight from outside 
the model. Suggested support settings are shown on the table below. 

Once supports have been finalized, the model must converted into G-code using a specific 
process and saved. Click ‘prepare to print’ and select the specific process for the printer. 



Simplify3D will use the profile settings in the process to construct a toolpath, which will be 
displayed in the primary window. The visible layers of the print can be selected with a slider, 
and the paths are colored by part type or toolhead speed. 

It is important to preview and inspect the generated toolpath before exporting it as a .gcode 
file. This allows problems with the model to be detected before starting a print that would fail 
because of a bad toolpath. Errors that can be found in the toolpath include overlapping parts 
for models that have not been repaired and features that are too small to print. Features should 
be large enough so that both the external shell and one internal perimeter shell can be printed. 

  
Support settings   

Support infill percentage 20% 

Extra inflation 0 

Dense support layers 1 

Dense infill 70 

Print support every 1 

Horizontal offset 0.2 

Upper vertical separation 1 

Lower vertical separation layers 0 
  

3.2.2) Simplify3D settings 
Extruder: Retraction is the pulling of the filament towards the drive gear, to minimize oozing. 
Bowden tube printers should use retraction distances between 4-8 mm. When printing with 
flexible materials, retraction should be minimized. 

Layer: Layer height is a tradeoff between print speed and resolution, a value of 0.2 mm is 
reasonable. 

Solid top and bottom layers will prevent gaps between the interior and exterior of the model in 
the Z axis. Seven layers is ample. 

The number of Perimeter shells determine the thickness of the exterior of the model in the XY 
axes. Values greater than two may be useful for very thin ribbon and stick models. 

It is essential for the first layer to adhere to the build plate. Running the first layer at 50% of the 
default speed on the ‘First layer settings’ will reduce print failures. 

Rafts and brims: Rafts and brims should always be included in the printer profile when printing 
molecular models. A brim is a thin outline of the shape of the model printed on the build plate, 
it ensures that the material in the hot end starts exiting the nozzle before critical parts of the 
print begin. 

A raft is a flat structure at the base of a print, connecting the build plate to the supports and the 
printed part. By increasing the surface area between the part and the build plate, the raft 
increases adhesion and prevents the part from becoming dislodged during the printing 
process. 



A raft is essential to printing any biomolecule. The efficacy of the raft can be increased by using 
1 raft layer, 6 mm offset from part, 0.0 mm separation distance, 100% raft infill, and disabling 
raft base layers. 

Infill: Infill is the material printed inside of the part. Surface models should be printed with 10-
20% infill, and ribbon models with at least 20-30% infill. 

Cooling: If printing with PLA or flexible filament, cooling should be turned on at the second 
layer. 

4. Post-production processing 
 
An alternative to manual support removal is use of a dissolvable support, but it requires a dual 
extrusion printer. In this process two filaments are used: (1) the model is printed with a primary 
material; (2) the supports with a secondary material. The secondary material is dissolved when 
the printed part is submerged in a solvent. Dual material printing is only possible with printers 
that use two nozzles or a hot end that can change materials. We find that printing with multiple 
materials greatly increases the number of possible points of failure in the printing process. The 
adhesion between different materials may not be strong enough to hold them together and the 
secondary nozzle may dislodge the print. The application of solvent is dangerous and requires 
a fume hood or outdoor space. The best of the bad combinations is an ABS model with PLA 
support, later dissolved using an aqueous base such as sodium hydroxide. We feel that the 
advantages of dissolvable support do not outweigh the costs. 
 

5. Printing instructions for models shown in figure 4 of the protocol 

5.1) HIV surface with glycoproteins and antibodies 

To simulate the HIV membrane (envelope), create a sphere with a radius of 100 nm and wall 
thickness of 10 nm in Autodesk Netfabb. To simplify the model and make it smaller, cut the 
sphere to give a spherical segment. Make the viral spikes by generating a surface model of 
the gp120 trimer ectodomain of the (PDB: 5FUU) and manually add a transmembrane and 
internal domain that mimics the 3 helices unresolved in the structure. The spikes were 
randomly distributed over the envelope at a frequency similar the native population measured 
by EM studies. Print the membrane (here in yellow) and the glycoprotein (here green) using a 
dual extrusion PLA printer (Flashforge Creator Pro in our case). Print the IgG antibodies (PDB: 
1IGT) separately and attach using a spot of modeling clay or blue tack. 

5.2) HIV protein surface with antibody ribbons 

Download the coordinates of the crystal structure of the glycosylated HIV envelope trimer in 
complex with 3 broadly neutralizing antibodies (PDB: 5FYJ). Cut the model using planes in 
Netfabb to only the contact region between gp120 and the variable region of the antibody 
VRC01. Generate a surface model for the glycoprotein. Print the HIV protein fragment with 2 
filaments - in our case blue for glycosylations and green for protein. Create a ribbon 
representation of the antibody fragment, add a disc for support, and reveal the side chains that 
contact the HIV protein. Add extensive support or the ribbons will not print correctly. Print the 
antibody in 2 colors corresponding to the heavy and light chain. Assemble the puzzle. There's 
only 1 position at which the antibody fits well over the HIV protein. Test your colleagues. 

5.3) Ribosomal complexes  

Download the structure of the thermus thermophilus 70S ribosome in complex with mRNA and 
3 tRNAs occupying A-, P- and E-sites (PDB: 4V5D). Generate a molecular surface for all 
chains. Left - Print the model in 2 colors to represent ribosomal RNA ( here red) and protein 
components (blue) followed by printing tRNAs in flexible material (white). This will enable you 
to fit them into the rigid ribosome cavities. Alternatively (right), print the ribosome in one color 



(white) and the transfer RNAs in another (green) to highlight their position. Add the mRNA 
(red) and the exiting polypeptide (blue) by gluing in 1.7 mm filaments at the right positions. The 
exit channel is located at the back of the large ribosomal subunit. If not blocked by support the 
green of the tRNA can be seen. 

6. Failures, common problems, and solutions 
To alert the user to some of the challenges encountered when using desktop 3D printers, we 
have compiled common issues that occur and possible solutions. Comprehensive support 
resources are available online to help with troubleshooting, including Simplify3D support 
guides (https://www.simplify3d.com/support/). 
  
6.1) Unleveled build plate 
Problem: If the build plate is horizontally levelled not leveled it will cause the extruder to be 
too close to it in some regions, preventing filament from being extruded, and too far in other 
regions, preventing filament from sticking to the build plate. 
Solution: Level the build plate, usually done manually using knobs on the bottom, and ensure 
that when Z axis is on the home position there’s a small distance between the nozzle and the 
build plate, sufficient for a piece of paper to be slid through with a little friction. 
 
6.2) Print detaches from build plate 
Problem: Sometimes the print may detach from the build plate by being knocked off if it’s base 
touching the build plate is too small, or if the adhesion to the bed is insufficient, as can happen 
in a heated build plate that’s not hot enough. 
Solution: Adding rafts during slicing greatly reduces chances of detachment. Some materials 
adhere to the bed better than others. PLA adheres especially well, while for other materials 
such as ABS, PET and Nylon it is much harder to obtain good layer adhesion. 
  
6.3) Supports knocked off 
Problem: Since supports are often tall with small bases, they can easily be knocked off if the 
first layer adhesion is not good. 
Solution: To avoid this, rafts can be used, as they provide a base to which supports adhere 
very well when extruded. Because molecular models have many supports, rafts are highly 
recommended. 
  
6.4) Nozzle clog 
Problem: Clogs can have several causes, such as accumulation of degraded material on the 
walls of the extruder and reduces flow rate, or inconsistencies in the diameter of the filament, 
making it too thick to fit the hot end. Sometimes the filament may be ground by the driving 
gear, resulting in a piece of filament stuck in the hot end. 
Solution: The best way to prevent clogs is to periodically drill the printer nozzle, so as to 
remove material that is adhering to the nozzle wall. Additionally, lubricating filament with 
mineral oil by having it pass through a sponge with a few drops of oil on top of the extruder 
also reduces clogging, because it reduces friction with the extruder walls and accumulation of 
material. When a clog occurs, if pushing the material down is not sufficient, the hot end must 
be disassembled and cleaned. 
  
6.5) Filament tangle 
Problem: if there is a knot in the filament spool or if it tangles around the spool holder, material 
flow will stop, and if this happens even for one layer, the print will be compromised. 
Solution: It is nearly impossible to prevent tangles when the filament spool has a knot and it 
happens in the middle of the print, unless someone sees the table and reacts in time. Ensuring 
that the spool holder is good and can rotate freely is the only other thing that can be done. 
  
6.6) Material accumulation on the hot end 



Problem: If part of the printer is knocked off or it detaches, and extruded material starts 
adhering to the hot end, a large blob of material can form on the extruder if the print is left 
going for a long time (such as overnight prints). This is the worst kind of failure, and in rare 
occasions so much material may accumulate on the extruder that it becomes impossible to 
remove without damaging the wires, and the whole hot end needs to be replaced. 
Solution: Other than checking the print periodically and using rafts to ensure it won’t detach, 
there is not much else that can be done. This kind of clob can only break the extruder if left 
unattended for several hours as in overnight prints, so it is very rare. 
  
6.7) Warping 
Problem: If the model being printed has a large continuous surface, the contraction of the 
extruded material as it cools down can cause the entire model to warp. 
Solution: Increasing room temperature diminishes warping. Industrial printers (which usually 
print in ABS) keep the chamber temperature at 80°C or above, preventing warping altogether. 
Warping also changes considerably depending on material. PLA is very good in this regard, 
whereas ABS, PET and Nylon are very prone to warp during cool-down. 
  
6.8) Filament kink 
Problem: For some extruder assemblies where there is significant space between the driving 
gear and the hot end tube, flexible material may kink and curl around the driving gear, instead 
of being pushed down. The same thing may happen with hard plastics if they heat too much 
and become soft prior to being pushed down the extruder due to insufficient cooling. 
Solution: Some extruder assemblies, such as those using bowden tubes, generally can’t print 
flexible materials. If PLA or other plastics are curling around the driving gear, something might 
be wrong with the insulation between the hot end and the driving gear assembly, or the cooling 
fan might not be working. 
 
7. Uploading files to the NIH 3D Print Exchange 
The NIH 3D Print Exchange is an online repository of biomedical models. It can be used to 
process 3D model files with the full Netfabb capabilities when models are uploaded to the 
repository. 
  

● To use or upload a model to the NIH 3D Print Exchange, navigate to 
http://3dprint.nih.gov. Log in or create an account. 

● Go to the ‘Share’ page on the 3D Print Exchange. Select the category that most clearly 
defines your model. 

● Upload the 3D STL file exported from Chimera. Add relevant additional information, 
e.g. title, description, references, pictures, printing guidelines, authorship and licensing. 

● On the ‘Upload your files’, mark the checkbox ‘Ensure printability with Netfabb’. The 3D 
Print Exchange will automatically process the file and will host the file on a model page 
created for the upload. User must publish the model before the files are made available 
for download. 

http://3dprint.nih.gov/
http://3dprint.nih.gov/
http://3dprint.nih.gov/
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