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Editing 4D Movies with ImageJ Plugins 

 
The goal is to edit a 4D movie to display only one or a few spots. An edited movie can be 
analyzed to quantify the fluorescence time courses. 
 
Typical Workflow 
This procedure assumes that you are starting with a deconvolved and bleach corrected 
movie in the form of a 4D TIFF hyperstack. The description is for a movie with three 
fluorescence channels plus a fourth channel for the cell images, but if there are fewer 
fluorescence channels, the procedure is essentially the same. 
 
The custom plugins for 4D movies should be placed in a folder within the ImageJ 
“plugins” folder. Detailed instructions for using these plugins are provided in later 
sections of this document. 
 
1. Run the “Make Montage Series” plugin, and choose the 4D TIFF hyperstack. The 

result will be a scaled montage with adjusted gray values for the cells. In addition, 
the blue channel color will be adjusted to make the signal easier to see. Save this 
montage series. 

 
2. Run the “Montage Series to Hyperstack” plugin. The result will be a 4D hyperstack 

that includes the adjustments described above. Save this hyperstack. 
 
3. Run the “Project Hyperstack” plugin. The result will be an average projected 

composite TIFF movie showing all of fluorescence signals. Save this original movie. 
 
4. View the original movie, and identify one or more structures that can potentially be 

followed cleanly in all three fluorescence channels. Note the positions and times at 
which those structures are present. 

 
5. Run the “Edit Montage Series” plugin. Choose the previously saved montage series, 

and create a copy for editing. 
 
6. Edit each fluorescence channel of this montage series so that it displays only the 

structure of interest in all three channels. Erase all of the extraneous fluorescence 
signals. Save this edited montage series. 

 
7. If additional structures of interest were identified, repeat steps #5 and #6, creating 

an additional edited montage series for each structure. 
 
8. Run the “Montage Series to Hyperstack” plugin for each edited montage series. Save 

these edited hyperstacks. 
 
9. To quantify the fluorescence signals from each isolated structure, run the “Analyze 

Edited Movie” plugin for the appropriate edited hyperstack. Save the results. 
 
10. If you wish to show more than one isolated structure in a combined edited movie, 

run the “Merge Two Hyperstacks” plugin and merge the first two edited hyperstacks. 
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The same plugin can be run again to merge in additional edited hyperstacks. Save 
the merged edited hyperstack, which can be projected to make the edited movie. 

 
11. If you wish to show the original movie above the edited movie, run the “Merge 

Hyperstacks” plugin again, but this time choose the option of placing the original 
hyperstack above the edited one. 

 
12. Once you have a fully processed hyperstack, run the “Project Hyperstack” plugin. 

Save the resulting final movie.  
 
13. If you wish to make changes in how the fluorescence signals were edited, go back and 

edit the appropriate montage series, then regenerate the final movie. 
 
14. As described below, use ImageJ to adjust the display parameters for the final movie 

if desired, and then generate an MP4 version of the final movie. 
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Plugin: Make Montage Series 
1. Run the plugin, and choose a 4D 8-bit TIFF hyperstack from a confocal. This data set 

should already be deconvolved, bleach corrected, and cropped if desired. 
 
2. Choose a scale factor for magnifying the individual slice images. The default value is 

4.0, but you can choose another number as long as the montage will fit on the screen. 
 
3. Choose the slices that will be used to create the montage. You can omit slices that 

have no fluorescence data. (Alternatively, such slices can be removed ahead of time 
by editing the hyperstack in ImageJ.) 

 
4. Allow the montage series to be created. The plugin cannot be aborted during scaling, 

but can be aborted using Esc during assembly of the montage series. 
 
5. Save the montage series, which will serve as the “original” montage series during the 

editing phase. 
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Plugin: Edit Montage Series 
1. Run the plugin, and open the original montage series. 
 
2. The first time you work with a given montage series, choose the option “Create New 

Montage” to duplicate the original montage series. 
 
 If you have already begun editing the montage series, use “Open Existing Montage”, 

and choose the edited montage series. 
 
 In either case, the edited version of the montage series will be displayed on top of the 

original version. 
 
3. Use the keyboard commands listed below to work with the original and edited 

montage series. You can also use the sliders at the bottom of the window. It is 
recommended to use these controls whenever possible rather than the standard 
ImageJ menu commands and image adjustment dialogs. 

 
a) Use Tab to switch between the original and edited montage series windows. 

These two windows should stay synchronized with respect to channel, time point, 
and display parameters. 

 
b) Use the Left Arrow and Right Arrow keys to move between time points. You can 

also drag the lower slider. 
 
c) Use Opt together with the Left Arrow and Right Arrow keys to switch between 

channels. You can also drag the upper slider. 
 
d) Use the Up Arrow and Down Arrow keys to increase or decrease the display 

brightness of the currently selected channel. 
 
 Use Opt together with the Up Arrow and Down Arrow keys to jump to either the 

default brightness, or the maximum or minimum brightness, depending on the 
current brightness setting of the currently selected channel. 

 
e) Use the R, G, and B keys (uppercase or lowercase) to toggle visibility of the red, 

green, and blue channels, respectively. Use the Y key to toggle visibility of the 
gray channel showing the cells. 

 
f) With the edited montage series visible, use the Z key to replace the edited 

contents of the currently displayed channel and time point with the original 
contents. 

 
 Note that Z is not a generic Undo key. This replacement function is irreversible. 
 
g) Use the A key to select the entire image. 
 
h) Use the E key to erase all of the fluorescence in the selected channel going 

forward or back in time. You will be prompted to choose the direction. 
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i) To delete everything except the desired spot, first select the spot in each of the 
relevant slices by drawing regions of interest (ROIs). A fast method for drawing 
ROIs is described below in (j). 

 
 You can use Shift to add pixels to an existing ROI, or Opt to trim pixels from an 

existing ROI. 
 
 When you are satisfied with the ROI, press the Delete key. For the currently 

selected channel, the nonselected pixels outside the ROI will be deleted. 
 
 If you make a mistake, reverse the procedure by pressing Z. 
 
 If you want to delete the selected pixels inside the ROI, use Opt together with the 

Delete key. If nothing is selected, the entire image will be deleted. 
 
j) To automatically trace a spot in all of the relevant slices, do the following. First, 

select the spot by drawing a crude ROI. Make sure the appropriate channel is 
selected. Then press Return. The spot will be outlined in the original slice and in 
the adjacent slices. 

 
 If you change the brightness using the Up Arrow and Down Arrow keys, and then 

repeat the automatic tracing, the borders will expand or contract accordingly. 
 
 If the automatic tracing captures too much or too little, you can add to the 

selection using the Shift key or remove part of the selection using the Opt key. 
 
4. Periodically save the edited montage series. The S key will work for this purpose. You 

can return to the edited file later if you wish to make additional edits. 
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Plugin: Montage Series to Hyperstack 
1. Open an edited montage series. 
 
2. Run the plugin. Choose the desired time points to generate an edited hyperstack. 
 
3. This edited hyperstack can be merged with other hyperstacks as described below, or 

it can be projected to make a 4D movie. In addition, it can be quantified using the 
Analyze Edited Movie plugin described below. 
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Plugin: Analyze Edited Movie 
1. Open a hyperstack generated from an edited montage series. 
 
2. Run the plugin. You will need to enter the time interval between Z-stacks. 
 
3. The results will be displayed in a window.  
 
 “Red”, “Green”, and “Blue” are the total signals from the Z-stacks at each of the 

indicated time points. 
 
“Red Integrated”, “Green Integrated”, and “Blue Integrated” are the time-dependent 
numerical integrals of the signals. 
 

4. If you click on this window and then save, the result will be a file that can be opened 
by Excel. You can then plot the data to show the primary or integrated fluorescence 
signals over time. 
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Plugin: Merge Two Hyperstacks 
1. Run this plugin, and choose two hyperstacks generated by the “Montage Series to 

Hyperstack” plugin.  
 
2. If you want to merge two edited hyperstacks to show two isolated structures in the 

same movie, choose the default “Merge fluorescence signals” option.  
 

If desired, the resulting hyperstack can be used as the input for another iteration to 
merge in data for a third isolated structure, and so on. 
 

3. If you want to show the original movie above the edited movie, choose the “Place 
first above second” option.  

 
First choose the hyperstack corresponding to the original movie. Then choose the 
hyperstack corresponding to the edited movie, which may show two or more isolated 
structures as described in step #2. 
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Plugin: Project Hyperstack 
1. Open a hyperstack that was either generated directly by the “Montage Series to 

Hyperstack” plugin, or further processed using the “Merge Two Hyperstacks” plugin. 
 
 If desired, you can examine this hyperstack to see if there are slices at the top or 

bottom that contain either no fluorescence throughout the time course, or 
extraneous background fluorescence. 

 
2. Run the “Project Hyperstack” plugin. When prompted, choose whether to project all 

of the slices, or to remove undesired slices from the top or bottom of the stack. 
 
 Make sure that “Average intensity” is chosen for the projection. You can choose to 

project all of the time points, or just a subset if desired. 
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Adjusting and Converting the Final Movie 
1. The result of the “Project Hyperstack” plugin should be a movie that is easy to view 

and appropriately scaled. However, you can adjust the output for each channel as 
follows. 

 
a) Choose Image > Adjust > Brightness/Contrast. In the projected movie, use the 

“c” slider to choose the channel (red, green, blue, or gray) that will be adjusted. 
 
b) Adjust the “Maximum” slider as desired to set the output of a given fluorescence 

channel.  
 

Alternatively, click “Auto” and then drag the “Minimum” slider back to “0”. 
 
Alternatively, click “Set” and specify the values manually. This approach is 
particularly useful if you wish to have identical display values for two movies, 
e.g., an original and an edited movie. 
 

c) Another way to adjust a channel is by choosing Process > Enhance Contrast. A 
value of 0.1% saturated pixels will give the same result as the “Project 
Hyperstack” plugin. You can vary this number as desired. 

 
2. To add a time stamp, choose Image > Stacks > Label. Use the format 00:00, with the 

appropriate time interval in seconds.  
 

To place the label in the lower left corner, set the Y location to be 1 less than the Y 
value of the lowest row of pixels.  
 
To place the label in the lower right corner, also set the X location to be 55 less than 
the X value of the rightmost column of pixels. 

 
3. To make a movie for publication, choose File > Save As > AVI. For the compression, 

choose PNG. A frame rate of 10 fps is typically suitable. 
 
 Convert the AVI file to MP4 format at https://video.online-convert.com/convert-to-

mp4. 


